Networking People
Document on loopback Test

Home

Basic | Click here for Notes on Loopback Test | What is GRE tunneling all about? | Using Ghost | About Me | My resume | Contact me | Dedicated To
What is Loop Back ?

Introduction

Loopbacks are an important part of troubleshooting; they are used to isolate the fault on and end-to-end circuit (especially when the circuit is down). This document examines the two types of loopbacks on Cisco router ATM interfaces:

  • loopback diagnostic - this helps you determine if your interface is working properly.

  • loopback line - this helps determine if there is a problem with the service provider.

Note 1: The examples in this document do not require any particular software versions. The AIP supports loopback diagnostic while PA-A1, PA-A2 and PA-A3 support both modes. The LANE modules support loopback line and other Cisco routers support both modes.

Note 2 : This applies only to the main interface, not the subinterface.

Network Diagram

We will use the following network to illustrate the loopback modes.

Loopback Diagnostic

The loopback diagnostic command under an ATM interface of a Cisco router causes traffic going out of the interface to come back to the router. Figure 1 and Example 1 illustrate how that process. To see loopback information for non-ATM interfaces, please click here and scroll down to the section on Special Serial Line Tests.

Note 1: Tx=transmit interface and Rx=Receive interface.

Note 2: To ensure proper clocking, set the router as the clock source. To do this, specify the atm clock internal setting in the main interface configuration.

Example 1

Before loopback diagnostic is set on the interface

LT-7507b

 

lt7507b# show running-config
Building configuration...
Current configuration:
!
version 12.0
!
hostname lt-7507b
!
ip subnet-zero
no ip domain-lookup
!
interface ATM1/0
no ip address
no ip directed-broadcast
no ip mroute-cache
no atm ilmi-keepalive
!
interface ATM1/0.1 multipoint
ip address 10.1.1.2 255.255.255.0
no ip directed-broadcast
pvc 0/85
protocol ip 10.1.1.1
encapsulation aal5snap
!
ip classless
no ip http server
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
 

lt-7507b# show interface atm 1/0
ATM1/0 is up, line protocol is up
Hardware is cxBus ATM
MTU 4470 bytes, sub MTU 4470, BW 155520 Kbit, DLY 80 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ATM, loopback not set
Keepalive not supported
Encapsulation(s): AAL5, PVC mode
256 TX buffers, 256 RX buffers,
2048 maximum active VCs, 1024 VCs per VP, 1 current VCCs
VC idle disconnect time: 300 seconds
Last input 00:01:55, output 00:01:55, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
163861 packets input, 3164940 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
33 input errors, 33 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
144191 packets output, 2138298 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out

Note: To illustrate the loopback mechanism, we will show that we can send ATM cells on the PVC. If loopback is not set, those cells will not be loopbacked to us. Let's shut down the ATM interface at the other router lt-7200b.

 
lt-7507b#debug atm packet interface
a1/0.1 vc 0/85
ATM packets debugging is on
Displaying packets on interface ATM1/0 VPI 0, VCI 85 only
 
lt-7507b#ping
Protocol [ip]:
Target IP address: 10.1.1.1
Repeat count [5]: 2
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 2, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:

The ping fails, and ATM debug show traffic is going out and not coming back.

 
1w1d: ATM1/0.1(O):

VCD:0x5 VPI:0x0 VCI:0x55 DM:0x100 SAP:AAAA CTL:03 OUI:000000
TYPE:0800 Length:0x70
1w1d: 4500 0064 001C 0000 FF01 B778 0A01 0102 0A01 0101 0800 9994
0E58 068B 0000
1w1d: 0000 2D42 A290 ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD
ABCD ABCD ABCD
1w1d: ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD
ABCD ABCD ABCD
1w1d: ABCD ABCD ABCD ABCD ABCD
1w1d: .

1w1d: ATM1/0.1(O):
VCD:0x5 VPI:0x0 VCI:0x55 DM:0x100 SAP:AAAA CTL:03 OUI:000000
TYPE:0800 Length:0x70
1w1d: 4500 0064 001D 0000 FF01 B777 0A01 0102 0A01 0101 0800 91C3
0E59 068B 0000
1w1d: 0000 2D42 AA60 ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD
ABCD ABCD ABCD
1w1d: ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD
ABCD ABCD ABCD
1w1d: ABCD ABCD ABCD ABCD ABCD
1w1d: .

Success rate is 0 percent (0/2)

Now add loopback diagnostic, and show interface will show that loopback is set.

 
lt-7507b#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.

lt-7507b(config)#int a1/0
lt-7507b(config-if)#loopback diagnostic lt-7507b(config-if)#atm clock internal

Note: The loopback command must be configured on a main interface, not on a subinterface.

 
lt-7507b# show interface a1/0

ATM1/0 is up, line protocol is up
Hardware is cxBus ATM
MTU 4470 bytes, sub MTU 4470, BW 155520 Kbit, DLY 80 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ATM, loopback set
Keepalive not supported
Encapsulation(s): AAL5, PVC mode
256 TX buffers, 256 RX buffers,
2048 maximum active VCs, 1024 VCs per VP, 1 current VCCs
VC idle disconnect time: 300 seconds
Last input 00:03:16, output 00:03:16, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
163861 packets input, 3164940 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
33 input errors, 33 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
144191 packets output, 2138298 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 output buffer failures, 0 output buffers swapped out

The ping will fail but the ATM debug will show traffic going out (O) and coming back in (I).

 
lt-7507b#ping

Protocol [ip]:
Target IP address: 10.1.1.1
Repeat count [5]: 2
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 2, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
 
1w1d: ATM1/0.1(O):

VCD:0x5 VPI:0x0 VCI:0x55 DM:0x100 SAP:AAAA CTL:03 OUI:000000
TYPE:0800 Length:0x70
1w1d: 4500 0064 001A 0000 FF01 B77A 0A01 0102 0A01 0101 0800 119A
13A2 07C5 0000
1w1d: 0000 2D41 2408 ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD
ABCD ABCD ABCD
1w1d: ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD
ABCD ABCD ABCD
1w1d: ABCD ABCD ABCD ABCD ABCD

1w1d:

1w1d: ATM1/0.1(I):

VCD:0x5 VPI:0x0 VCI:0x55 Type:0x0 SAP:AAAA CTL:03 OUI:000000
TYPE:0800 Length:0x70
1w1d: 4500 0064 001A 0000 0101 B57B 0A01 0102 0A01 0101 0800 119A
13A2 07C5 0000
1w1d: 0000 2D41 2408 ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD
ABCD ABCD ABCD
1w1d: ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD
ABCD ABCD ABCD
1w1d: ABCD ABCD ABCD ABCD ABCD
1w1d: .

1w1d: ATM1/0.1(O):

VCD:0x5 VPI:0x0 VCI:0x55 DM:0x100 SAP:AAAA CTL:03 OUI:000000
TYPE:0800 Length:0x70
1w1d: 4500 0064 001B 0000 FF01 B779 0A01 0102 0A01 0101 0800 09C9
13A3 07C5 0000
1w1d: 0000 2D41 2BD8 ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD
ABCD ABCD ABCD
1w1d: ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD
ABCD ABCD ABCD
1w1d: ABCD ABCD ABCD ABCD ABCD
1w1d:

1w1d: ATM1/0.1(I):

VCD:0x5 VPI:0x0 VCI:0x55 Type:0x0 SAP:AAAA CTL:03 OUI:000000
TYPE:0800 Length:0x70
1w1d: 4500 0064 001B 0000 0101 B57A 0A01 0102 0A01 0101 0800 09C9
13A3 07C5 0000
1w1d: 0000 2D41 2BD8 ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD
ABCD ABCD ABCD
1w1d: ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD
ABCD ABCD ABCD
1w1d: ABCD ABCD ABCD ABCD ABCD
1w1d: .

Success rate is 0 percent (0/2)

Loopback Line

The loopback line command under an ATM interface of a Cisco router causes incoming traffic to be sent back to the network. See Figure 2 and Example 2 below.

Example 2

Configuration of router lt-7200b

LT-7200b

 


lt-7200b# show running-config
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname lt-7200b
!
interface ATM2/0
no ip address
no ip directed-broadcast
no atm ilmi-keepalive
!
interface ATM2/0.1 multipoint
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast
pvc 0/85
protocol ip 10.1.1.2
encapsulation aal5snap
!
!
ip classless
no ip http server
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
 

Before loopback line is set on the interface

 
lt-7200b# show interface atm 2/0

ATM2/0 is up, line protocol is up
Hardware is TI1570 ATM
MTU 4470 bytes, sub MTU 4470, BW 155520 Kbit, DLY 80 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ATM, loopback not set
Keepalive not supported
Encapsulation(s): AAL5, PVC mode
2048 maximum active VCs, 1024 VCs per VP, 1 current VCCs
VC idle disconnect time: 300 seconds
Last input 00:00:43, output 00:00:43, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
94912 packets input, 1637823 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
102893 packets output, 2042225 bytes, 0 underruns
0 output errors, 0 collisions, 3 interface resets
0 output buffer failures, 0 output buffers swapped out

Note: ATM packets debugging is on and ping from router lt-7507b to router lt-7200b. You can see that the tests are done again from the 7500 (where we removed the initial loopback). This is normal since the Loopback Line allows us to see if the Telco's network is working properly.

 
lt-7507b#debug atm packet
ATM packets debugging is on
Displaying all ATM packets
lt-7507b#debug atm packet sh debug
 
lt-7507b#ping 10.1.1.1
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!
Success rate is 100 percent (1/1), round-trip min/avg/max = 1/2/4 ms

 
The ping is successful, and ATM debug show traffic is going out and coming back in.

 
00:45:14: ATM1/0.1(O):

VCD:0x1 VPI:0x0 VCI:0x55 DM:0x100 SAP:AAAA CTL:03 OUI:000000
TYPE:0800 Length:0x70
00:45:14: 4500 0064 0005 0000 FF01 B78F 0A01 0102 0A01 0101 0800 028C
02D4 0C51 0000
00:45:14: 0000 0029 6C70 ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD
ABCD ABCD ABCD
00:45:14: ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD
ABCD ABCD ABCD
00:45:14: ABCD ABCD ABCD ABCD ABCD
00:45:14:

00:45:14: ATM1/0.1(I):
VCD:0x1 VPI:0x0 VCI:0x55 Type:0x0 SAP:AAAA CTL:03 OUI:000000
TYPE:0800 Length:0x70
00:45:14: 4500 0064 0005 0000 FE01 B88F 0A01 0101 0A01 0102 0000 0A8C
02D4 0C51 0000
00:45:14: 0000 0029 6C70 ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD
ABCD ABCD ABCD
00:45:14: ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD
ABCD ABCD ABCD
00:45:14: ABCD ABCD ABCD ABCD ABCD
     
    Success rate is 100 percent (1/1)

Configure loopback line on the ATM interface of router lt-7200b

 
lt-7200b#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
lt-7200b(config)#int a2/0
lt-7200b(config-if)#loopback line
lt-7200b(config-if)#^Z

lt-7200b#config show interface a2/0
ATM2/0 is up, line protocol is up
Hardware is TI1570 ATM
MTU 4470 bytes, sub MTU 4470, BW 155520 Kbit, DLY 80 usec,
reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ATM,loopback set
Keepalive not supported
Encapsulation(s): AAL5, PVC mode
2048 maximum active VCs, 1024 VCs per VP, 1 current VCCs
VC idle disconnect time: 300 seconds
Last input 00:02:45, output 00:02:45, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
94917 packets input, 1638383 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
102898 packets output, 2042785 bytes, 0 underruns
0 output errors, 0 collisions, 5 interface resets
0 output buffer failures, 0 output buffers swapped out

Note: Ping from the router lt-7507b. The ping will fail as expected, but the traffic is looped back towards router lt-7507b from the network, and the ATM debug shows the traffic going out (O) and then coming back in (I).

 
lt-7507b#ping 10.1.1.1
 
Type escape sequence to abort.
Sending 2, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
..
Success rate is 0 percent (0/2)
 
00:52:00: ATM1/0.1(O):
VCD:0x1 VPI:0x0 VCI:0x55 DM:0x100 SAP:AAAA CTL:03 OUI:000000
TYPE:0800 Length:0x70
00:52:00: 4500 0064 000F 0000 FF01 B785 0A01 0102 0A01 0101 0800 CE44 1
21D 0009 0000
00:52:00: 0000 002F 9DB0 ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD
ABCD ABCD ABCD
00:52:00: ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD
ABCD ABCD ABCD
00:52:00: ABCD ABCD ABCD ABCD ABCD
00:52:00:

00:52:00: ATM1/0.1(I):
VCD:0x1 VPI:0x0 VCI:0x55 Type:0x0 SAP:AAAA CTL:03 OUI:000000
TYPE:0800 Length:0x70
00:52:00: 4500 0064 000F 0000 0101 B586 0A01 0102 0A01 0101 0800 CE44
121D 0009 0000
00:52:00: 0000 002F 9DB0 ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD
ABCD ABCD ABCD
00:52:00: ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD
ABCD ABCD ABCD
00:52:00: ABCD ABCD ABCD ABCD ABCD
00:52:00: .

00:52:02: ATM1/0.1(O):
VCD:0x1 VPI:0x0 VCI:0x55 DM:0x100 SAP:AAAA CTL:03 OUI:000000
TYPE:0800 Length:0x70
00:52:02: 4500 0064 0010 0000 FF01 B784 0A01 0102 0A01 0101 0800 C673
121E 0009 0000
00:52:02: 0000 002F A580 ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD
ABCD ABCD ABCD
00:52:02: ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD
ABCD ABCD ABCD
00:52:02: ABCD ABCD ABCD ABCD ABCD
00:52:02:

00:52:02: ATM1/0.1(I):
VCD:0x1 VPI:0x0 VCI:0x55 Type:0x0 SAP:AAAA CTL:03 OUI:000000
TYPE:0800 Length:0x70
00:52:02: 4500 0064 0010 0000 0101 B585 0A01 0102 0A01 0101 0800 C673
121E 0009 0000
00:52:02: 0000 002F A580 ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD
ABCD ABCD ABCD
00:52:02: ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD
ABCD ABCD ABCD
00:52:02: ABCD ABCD ABCD ABCD ABCD

Success rate is 0 percent (0/2)

Conclusion

Loopbacks are a useful tool to use when you are troubleshooting failed circuits. They can:

  • help you determine physical interface problems.

  • help you troubleshoot ATM service providers.

We ran the tests in this document in the usual way: pinging the other side. If you use the right mapping, or if you use a point-to-point sub-interface, the user could ping his own IP address. Therefore, the ICMP echo would definitely be sent on the interface and would be answered by the router. In other words, in a live environment, you can run the same tests without any debugging enabled. You can simply check if you can ping your own IP address and see if the test succeeds.

                                                                  All Rights Reserved To :
                                                                 Praveen G.Pandit,System Engineer,Bangalore,India.